extractChangeSummaries MethodStatic
Deprecated in 2.x. Use ChangeSummaryManager.createChangeSummaries instead
Extracts change summaries from the specified iModel. Change summaries are extracted from the version the iModel was opened with up through the specified start version. If no start version has been specified, the first version will be used.
extractChangeSummaries(accessToken: string, iModel: BriefcaseDb, options?: ChangeSummaryExtractOptions): Promise<string[]>
throws IModelError if the iModel is standalone
Parameter | Type | Description |
---|---|---|
accessToken | string | A valid access token string |
iModel | BriefcaseDb | iModel to extract change summaries for. The iModel must not be a standalone iModel. Note: For every version to extract a summary from, the method moves the iModel to that version before extraction. After the extraction has completed, the iModel is moved back to the original version. |
options | ChangeSummaryExtractOptions | Extraction options |
Returns - Promise<string[]>
the Ids of the extracted change summaries.
Defined in
- backend/src/ChangeSummaryManager.ts Line 156
Last Updated: 20 June, 2023