buildPropertyValueChangesECSql MethodStatic
Builds the ECSQL to query the property value changes for the specified instance change and the specified ChangedValueState.
See also Change Summary Overview
buildPropertyValueChangesECSql(iModel: IModelDb, instanceChangeInfo: { changedInstance: { className: string, id: string }, id: string, summaryId: string }, changedValueState: ChangedValueState, changedPropertyNames?: string[]): string
throws IModelError if instance change does not exist, if there are not property value changes for the instance change, if the change cache file hasn't been attached, or in case of other errors.
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | iModel |
instanceChangeInfo | { changedInstance: { className: string, id: string }, id: string, summaryId: string } | InstanceChange to query the property value changes for changedInstance.className must be fully qualified and schema and class name must be escaped with square brackets if they collide with reserved ECSQL words: [schema name].[class name] |
changedValueState | ChangedValueState | The Changed State to query the values for. This must correspond to the InstanceChange.OpCode of the InstanceChange. |
changedPropertyNames | string[] | List of the property names for which values have changed for the specified instance change. The list can be obtained by calling ChangeSummaryManager.getChangedPropertyValueNames. If omitted, the method will call the above method by itself. The parameter allows for checking first whether an instance change has any property value changes at all. If there are no property value changes, this method should not be called, as it will throw an error. |
Returns - string
Returns the ECSQL that will retrieve the property value changes
Defined in
- backend/src/ChangeSummaryManager.ts Line 466
Last Updated: 20 June, 2023