ChangeSummaryManager Class
Beta
Class to extract Change Summaries for a briefcase.
See also:
Methods
Name | Description | |
---|---|---|
constructor(): ChangeSummaryManager | ||
attachChangeCache(iModel: IModelDb): void Static | Attaches the Change Cache file to the specified iModel if it hasn't been attached yet. | |
buildPropertyValueChangesECSql(iModel: IModelDb, instanceChangeInfo: { changedInstance: { className: string, id: string }, id: string, summaryId: string }, changedValueState: ChangedValueState, changedPropertyNames?: string[]): string Static | Builds the ECSQL to query the property value changes for the specified instance change and the specified ChangedValueState. | |
createChangeSummaries(args: CreateChangeSummaryArgs): Promise<string[]> Static | Creates change summaries for the specified iModel and a specified range of versions | |
createChangeSummary(accessToken: string, iModel: BriefcaseDb): Promise<string> Static | Creates a change summary for the last applied change set to the iModel | Beta |
detachChangeCache(iModel: IModelDb): void Static | Detaches the Change Cache file from the specified iModel. | |
extractChangeSummaries(accessToken: string, iModel: BriefcaseDb, options?: ChangeSummaryExtractOptions): Promise<string[]> Static | Extracts change summaries from the specified iModel. | Deprecated |
getChangedPropertyValueNames(iModel: IModelDb, instanceChangeId: string): string[] Static | Retrieves the names of the properties whose values have changed for the given instance change | |
isChangeCacheAttached(iModel: IModelDb): boolean Static | Determines whether the Change Cache file is attached to the specified iModel or not | |
queryChangeSummary(iModel: BriefcaseDb, changeSummaryId: string): ChangeSummary Static | Queries the ChangeSummary for the specified change summary id | |
queryInstanceChange(iModel: BriefcaseDb, instanceChangeId: string): InstanceChange Static | Queries the InstanceChange for the specified instance change id. |
Defined in
Last Updated: 20 June, 2023