insert MethodStatic
Insert a TemplateRecipe2d and a DrawingModel (sub-model) that will contain the 2d template elements.
insert(iModelDb: IModelDb, definitionModelId: string, name: string, isPrivate?: boolean): string
throws IModelError if there is a problem inserting the TemplateRecipe2d or its sub-model.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The IModelDb |
definitionModelId | string | The Id of the DefinitionModel that contains this TemplateRecipe2d element. |
name | string | The name (Code.value) of the TemplateRecipe2d |
isPrivate | boolean |
Returns - string
The Id of the newly inserted TemplateRecipe2d and the PhysicalModel that sub-models it.
Defined in
- backend/src/Element.ts Line 1302
Last Updated: 20 June, 2023