insert MethodStatic
Insert a Subject
insert(iModelDb: IModelDb, parentSubjectId: string, name: string, description?: string): string
throws IModelError if there is a problem inserting the Subject
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this IModelDb |
parentSubjectId | string | The new Subject will be inserted as a child of this Subject |
name | string | The name (codeValue) of the Subject |
description | string | The optional description of the Subject |
Returns - string
The Id of the newly inserted Subject
Defined in
- backend/src/Element.ts Line 796
Last Updated: 20 June, 2023