create MethodStatic
Create a Subject
create(iModelDb: IModelDb, parentSubjectId: string, name: string, description?: string): Subject
throws IModelError if there is a problem creating the Subject
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The IModelDb |
parentSubjectId | string | The new Subject will be a child of this Subject |
name | string | The name (codeValue) of the Subject |
description | string | The optional description of the Subject |
Returns - Subject
The newly constructed Subject
Defined in
- backend/src/Element.ts Line 778
Last Updated: 20 June, 2023