create MethodStatic
Create a PhysicalMaterial
create<T extends PhysicalMaterial<T>>(iModelDb: IModelDb, definitionModelId: string, name: string): T
throws IModelError if there is a problem creating the PhysicalMaterial
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The IModelDb |
definitionModelId | string | The Id of the DefinitionModel that will contain the PhysicalMaterial and provide the scope for its name. |
name | string | The name (codeValue) of the PhysicalMaterial |
Returns - T
The newly constructed PhysicalMaterial
Defined in
- backend/src/Material.ts Line 41
Last Updated: 20 June, 2023