ElementTreeDeleter Class
Beta
Deletes an entire element tree, including sub-models and child elements.
Items are deleted in bottom-up order. Definitions and Subjects are deleted after normal elements.
Call deleteNormalElements on each tree. Then call deleteSpecialElements.
see deleteElementTree for a simple way to use this class.
Extends
Methods
Name |
Description |
|
constructor(_iModel: IModelDb): ElementTreeDeleter |
|
|
deleteNormalElements(topElement: string, scope?: ElementTreeWalkerScope): void |
Delete the "normal" elements and record the special elements for deferred processing. |
|
deleteSpecialElements(): void |
Delete all special elements that were found and deferred by deleteNormalElements. |
|
shouldExploreModel(_model: Model): boolean Protected |
Return true if the search should recurse into this model |
|
shouldVisitElement(_elementId: string): boolean Protected |
Return true if the search should visit this element |
|
visitElement(elementId: string, _scope: ElementTreeWalkerScope): void Protected |
Called to visit an element |
|
visitModel(model: Model, _scope: ElementTreeWalkerScope): void Protected |
Called to visit a model |
|
Inherited methods
Properties
Name |
Type |
Description |
|
_special Protected |
SpecialElements |
|
|
Inherited properties
Defined in
Last Updated:
20 June, 2023