insert MethodStatic
Insert a Drawing element and a DrawingModel that breaks it down.
insert(iModelDb: IModelDb, documentListModelId: string, name: string): string
throws IModelError if unable to insert the element.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this iModel |
documentListModelId | string | Insert the new Drawing into this DocumentListModel |
name | string | The name of the Drawing. |
Returns - string
The Id of the newly inserted Drawing element and the DrawingModel that breaks it down (same value).
Defined in
- backend/src/Element.ts Line 842
Last Updated: 20 June, 2023