StringTypeConverter Class
String Type Converter.
Extends
Implements
Methods
Name |
Description |
|
constructor(): StringTypeConverter |
|
|
contains(valueA: string, valueB: string, caseSensitive: boolean): boolean |
Determines if one string contains another string |
|
convertFromString(value: string): string |
Converts a string to a primitive value |
|
convertToString(value?: string): string |
Converts a primitive value to a string |
|
doesNotContain(valueA: string, valueB: string, caseSensitive: boolean): boolean |
Determines if one string does not contain another string |
|
endsWith(valueA: string, valueB: string, caseSensitive: boolean): boolean |
Determines if one string ends with another string |
|
isContainedIn(valueA: string, valueB: string, caseSensitive: boolean): boolean |
Determines if one string is contained within another string |
|
isEmpty(valueA: string): boolean |
Determines if a string is empty |
|
isNotContainedIn(valueA: string, valueB: string, caseSensitive: boolean): boolean |
Determines if one string is not contained within another string |
|
isNotEmpty(valueA: string): boolean |
Determines if a string is not empty |
|
sortCompare(valueA: string, valueB: string, ignoreCase?: boolean): number |
Sort function for two primitive values |
|
startsWith(valueA: string, valueB: string, caseSensitive: boolean): boolean |
Determines if one string starts with another string |
|
Inherited methods
Name |
Inherited from |
Description |
convertFromStringToPropertyValue(value: string, propertyRecord?: PropertyRecord): Promise<PropertyValue> |
TypeConverter |
Converts a string with a property record to a property value |
convertFromStringWithOptions(value: string, _options?: { T }): undefined | ConvertedPrimitives.Value | Promise<undefined | ConvertedPrimitives.Value> |
TypeConverter |
Default implementation just calls convertFromString with no options |
convertPropertyToString(propertyDescription: PropertyDescription, value?: Value): string | Promise<string> |
TypeConverter |
Converts a value associated with a property description to a string |
convertToStringWithOptions(value?: Value, _options?: { T }): string | Promise<string> |
TypeConverter |
Default implementation just calls convertToString with no options |
isEqualTo(valueA: Value, valueB: Value): boolean |
TypeConverter |
Determines if two primitive values are equal |
isNotEqualTo(valueA: Value, valueB: Value): boolean |
TypeConverter |
Determines if two primitive values are not equal |
isNotNull(value: Value): boolean |
TypeConverter |
Determines if a primitive value is not null or not undefined |
isNull(value: Value): boolean |
TypeConverter |
Determines if a primitive value is null or undefined |
Properties
Name |
Type |
Description |
|
isStringType Accessor ReadOnly |
boolean |
|
|
Inherited properties
Name |
Type |
Inherited from |
Description |
isBooleanType Accessor ReadOnly |
boolean |
TypeConverter |
Determines if the converter is for a boolean type |
isLessGreaterType Accessor ReadOnly |
boolean |
TypeConverter |
Determines if the converter is for a numeric type |
isNullableType Accessor ReadOnly |
boolean |
TypeConverter |
Determines if the converter is for a nullable type |
Defined in
Last Updated:
20 June, 2023