Point3dTypeConverter Class
Point3d type converter.
Extends
Methods
Name | Description | |
---|---|---|
constructor(componentConverterName?: string): Point3dTypeConverter | ||
constructPoint(values: Point): undefined | ConvertedPrimitives.Point3d Protected | ||
getVectorLength(point: Point): undefined | number Protected |
Inherited methods
Name | Inherited from | Description |
---|---|---|
convertFromString(value: string): undefined | ConvertedPrimitives.Point | BasePointTypeConverter | Converts a string to a primitive value |
convertFromStringToPropertyValue(value: string, propertyRecord?: PropertyRecord): Promise<PropertyValue> | BasePointTypeConverter | Converts a string with a property record to a property value |
convertFromStringWithOptions(value: string, _options?: { T }): undefined | ConvertedPrimitives.Value | Promise<undefined | ConvertedPrimitives.Value> | BasePointTypeConverter | Default implementation just calls convertFromString with no options |
convertPropertyToString(propertyDescription: PropertyDescription, value?: Value): string | Promise<string> | BasePointTypeConverter | Converts a value associated with a property description to a string |
convertToString(value?: Point): string | Promise<string> | BasePointTypeConverter | Converts a primitive value to a string |
convertToStringWithOptions(value?: Value, _options?: { T }): string | Promise<string> | BasePointTypeConverter | Default implementation just calls convertToString with no options |
isEqualTo(valueA: Value, valueB: Value): boolean | BasePointTypeConverter | Determines if two primitive values are equal |
isNotEqualTo(valueA: Value, valueB: Value): boolean | BasePointTypeConverter | Determines if two primitive values are not equal |
isNotNull(value: Value): boolean | BasePointTypeConverter | Determines if a primitive value is not null or not undefined |
isNull(value: Value): boolean | BasePointTypeConverter | Determines if a primitive value is null or undefined |
sortCompare(a: Point, b: Point, _ignoreCase?: boolean): number | BasePointTypeConverter | Sort function for two primitive values |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
componentConverterName | string | BasePointTypeConverter | |
isBooleanType Accessor ReadOnly | boolean | BasePointTypeConverter | Determines if the converter is for a boolean type |
isLessGreaterType Accessor ReadOnly | boolean | BasePointTypeConverter | Determines if the converter is for a numeric type |
isNullableType Accessor ReadOnly | boolean | BasePointTypeConverter | Determines if the converter is for a nullable type |
isStringType Accessor ReadOnly | boolean | BasePointTypeConverter | Determines if the converter is for a string type |
Defined in
Last Updated: 20 June, 2023