IntTypeConverter Class
Int Type Converter.
Extends
Methods
Name |
Description |
|
constructor(): IntTypeConverter |
|
|
convertFromString(value: string): undefined | number |
Converts a string to a primitive value |
|
convertToString(value?: Int): string |
Converts a primitive value to a string |
|
Inherited methods
Name |
Inherited from |
Description |
convertFromStringToPropertyValue(value: string, propertyRecord?: PropertyRecord): Promise<PropertyValue> |
NumericTypeConverterBase |
Converts a string with a property record to a property value |
convertFromStringWithOptions(value: string, _options?: { T }): undefined | ConvertedPrimitives.Value | Promise<undefined | ConvertedPrimitives.Value> |
NumericTypeConverterBase |
Default implementation just calls convertFromString with no options |
convertPropertyToString(propertyDescription: PropertyDescription, value?: Value): string | Promise<string> |
NumericTypeConverterBase |
Converts a value associated with a property description to a string |
convertToStringWithOptions(value?: Value, _options?: { T }): string | Promise<string> |
NumericTypeConverterBase |
Default implementation just calls convertToString with no options |
isEqualTo(valueA: Value, valueB: Value): boolean |
NumericTypeConverterBase |
Determines if two primitive values are equal |
isGreaterThan(a: Numeric, b: Numeric): boolean |
NumericTypeConverterBase |
Determines if a primitive values is greater than another primitive value |
isGreaterThanOrEqualTo(a: Numeric, b: Numeric): boolean |
NumericTypeConverterBase |
Determines if a primitive values is greater than or equal to another primitive value |
isLessThan(a: Numeric, b: Numeric): boolean |
NumericTypeConverterBase |
Determines if a primitive values is less than another primitive value |
isLessThanOrEqualTo(a: Numeric, b: Numeric): boolean |
NumericTypeConverterBase |
Determines if a primitive values is less than or equal to another primitive value |
isNotEqualTo(valueA: Value, valueB: Value): boolean |
NumericTypeConverterBase |
Determines if two primitive values are not equal |
isNotNull(value: Value): boolean |
NumericTypeConverterBase |
Determines if a primitive value is not null or not undefined |
isNull(value: Value): boolean |
NumericTypeConverterBase |
Determines if a primitive value is null or undefined |
sortCompare(a: Numeric, b: Numeric, _ignoreCase?: boolean): number |
NumericTypeConverterBase |
Sort function for two primitive values |
Inherited properties
Defined in
Last Updated:
20 June, 2023