BooleanTypeConverter Class
Boolean Type Converter.
Extends
Methods
Name | Description | |
---|---|---|
constructor(): BooleanTypeConverter | ||
convertFromString(value: string): boolean | Converts a string to a primitive value | |
convertToString(value?: Boolean): string | Converts a primitive value to a string | |
sortCompare(a: Boolean, b: Boolean, _ignoreCase?: boolean): number | Sort function for two primitive values |
Inherited methods
Name | Inherited from | Description |
---|---|---|
convertFromStringToPropertyValue(value: string, propertyRecord?: PropertyRecord): Promise<PropertyValue> | TypeConverter | Converts a string with a property record to a property value |
convertFromStringWithOptions(value: string, _options?: { T }): undefined | ConvertedPrimitives.Value | Promise<undefined | ConvertedPrimitives.Value> | TypeConverter | Default implementation just calls convertFromString with no options |
convertPropertyToString(propertyDescription: PropertyDescription, value?: Value): string | Promise<string> | TypeConverter | Converts a value associated with a property description to a string |
convertToStringWithOptions(value?: Value, _options?: { T }): string | Promise<string> | TypeConverter | Default implementation just calls convertToString with no options |
isEqualTo(valueA: Value, valueB: Value): boolean | TypeConverter | Determines if two primitive values are equal |
isNotEqualTo(valueA: Value, valueB: Value): boolean | TypeConverter | Determines if two primitive values are not equal |
isNotNull(value: Value): boolean | TypeConverter | Determines if a primitive value is not null or not undefined |
isNull(value: Value): boolean | TypeConverter | Determines if a primitive value is null or undefined |
Properties
Name | Type | Description | |
---|---|---|---|
isBooleanType Accessor ReadOnly | boolean |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
isLessGreaterType Accessor ReadOnly | boolean | TypeConverter | Determines if the converter is for a numeric type |
isNullableType Accessor ReadOnly | boolean | TypeConverter | Determines if the converter is for a nullable type |
isStringType Accessor ReadOnly | boolean | TypeConverter | Determines if the converter is for a string type |
Defined in
Last Updated: 20 June, 2023