useTreeModelSource Function
Custom hook which creates a TreeModelSource
.
useTreeModelSource(dataProvider: TreeDataProvider): TreeModelSource
note The model source has no direct dependency on the data provider, but we want a fresh model source whenever the data provider changes - that's the reason the hook takes a data provider.
Parameter | Type | Description |
---|---|---|
dataProvider | TreeDataProvider |
Returns - TreeModelSource
Defined in
Last Updated: 20 June, 2023