TreeModelSource Class
Controls tree model. It is used to modify model and inform when tree model changes.
Methods
Name | Description | |
---|---|---|
constructor(_model: MutableTreeModel = ...): TreeModelSource | ||
getModel(): TreeModel | Returns tree model. | |
modifyModel(callback: (model: MutableTreeModel) => void): void | Modifies tree model using provided callback. |
Properties
Name | Type | Description | |
---|---|---|---|
onModelChanged | BeUiEvent<[TreeModel, TreeModelChanges]> | Event that is emitted every time tree model is changed. |
Defined in
Last Updated: 20 June, 2023