CustomToolbarItem Interface
Describes the data needed to insert a custom React
button into an ToolbarWithOverflow.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
buttonNode | undefined | ReactNode | React node that must result in providing a PopupItem @deprecated in 3.x. | |
keepContentsLoaded | undefined | boolean | If true the popup panel is mounted once and unmounted when button is unmounted. | |
panelContentNode | undefined | ReactNode | defines the content to display in popup panel |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
applicationData Readonly | undefined | any | CustomButtonDefinition | can be used by application to store miscellaneous data. |
badgeType Readonly | undefined | BadgeType | CustomButtonDefinition | Describes badge. |
description Readonly | string | ConditionalStringValue | CustomButtonDefinition | Optional description |
groupPriority Readonly | undefined | number | CustomButtonDefinition | Specifies the item's grouping value. |
icon Readonly | string | ConditionalStringValue | CustomButtonDefinition | Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. |
id Readonly | string | CustomButtonDefinition | Require uniqueId for the item. |
internalData Readonly | undefined | Map<string, any> | CustomButtonDefinition | optional data to used by item implementor. |
isActive Readonly | undefined | boolean | CustomButtonDefinition | Defines if the item is active (shown with an active stripe/bar). |
isCustom Readonly | "true" | CustomButtonDefinition | parameter that marks data as being a custom definition. |
isDisabled Readonly | boolean | ConditionalBooleanValue | CustomButtonDefinition | Describes if the item is enabled or disabled. |
isHidden Readonly | boolean | ConditionalBooleanValue | CustomButtonDefinition | Describes if the item is visible or hidden. |
isPressed Readonly | undefined | boolean | CustomButtonDefinition | Describes if the item should appear pressed (used for displaying toggle state). |
itemPriority Readonly | number | CustomButtonDefinition | Priority within a toolbar or group. |
label Readonly | string | ConditionalStringValue | CustomButtonDefinition | label, shown as tool tip on group button or a group button label in a group panel. |
parentToolGroupId Readonly | undefined | string | CustomButtonDefinition | Optional parent tool group to add tool. |
providerId Readonly | undefined | string | CustomButtonDefinition | id of UiItemsProvider |
Defined in
Last Updated: 20 June, 2023