TableCellContextMenuArgs Interface
Deprecated in 3.0. Use the Table component in @itwin/itwinui-react instead, which does not use this interface.
Arguments for TableProps.onCellContextMenu
callback
Properties
Name | Type | Description | |
---|---|---|---|
cellItem | undefined | CellItem | CellItem of the cell clicked | |
cellKey | string | Key of the cell clicked | |
colIndex | number | Index of the column clicked | |
event | MouseEvent<Element, MouseEvent> | An event which caused the context menu callback | |
rowIndex | number | Index of the row clicked |
Defined in
Last Updated: 20 June, 2023