PropertyDataFilterResult Interface
Data structure for storing IPropertyDataFilterer matching results
Properties
Name | Type | Description | |
---|---|---|---|
filteredTypes | undefined | FilteredType[] | Indicates what item types were matched. | |
matchesCount | undefined | number | Indicates how many times filter was matched in the provided item. | |
matchesFilter | boolean | Indicates whether provided item matched filter | |
shouldExpandNodeParents | undefined | boolean | Indicates whether parents of node should be expanded up to this match node. | |
shouldForceIncludeDescendants | undefined | boolean | Indicates whether descendants nodes should be forcefully included in filtered results. |
Defined in
Last Updated: 20 June, 2023