IPropertyDataFilterer Interface
An interface for a filterer that filters PropertyData based on content of PropertyRecord and PropertyCategory objects.
Implemented by
Methods
Name | Description | |
---|---|---|
categoryMatchesFilter(node: PropertyCategory, parents: PropertyCategory[]): Promise<PropertyDataFilterResult> | ||
recordMatchesFilter(node: PropertyRecord, parents: PropertyRecord[]): Promise<PropertyDataFilterResult> |
Properties
Name | Type | Description | |
---|---|---|---|
isActive Readonly | boolean | ||
onFilterChanged | PropertyFilterChangeEvent |
Defined in
Last Updated: 20 June, 2023