createGridCategory Method
Converts category into GridCategoryItem.
createGridCategory(category: PropertyCategory, recordsDict: CategoryRecordsDict, parentSelectionKey?: string, depth?: number): IMutableGridCategoryItem
Parameter | Type | Description |
---|---|---|
category | PropertyCategory | PropertyCategory to convert. |
recordsDict | CategoryRecordsDict | dictionary of category records. |
parentSelectionKey | string | parent selection key of this category. |
depth | number | current depth counting from root category. |
Returns - IMutableGridCategoryItem
converted GridCategory.
Defined in
- ui/components-react/src/components-react/propertygrid/internal/flat-items/MutableGridItemFactory.ts Line 118
Last Updated: 20 June, 2023