EditorContainerProps Interface
EditorContainer React component properties
Extends
Methods
Name | Description | |
---|---|---|
onCancel(): void | Handler for cancel | |
onCommit(args: PropertyUpdatedArgs): void | Handler for commit |
Properties
Name | Type | Description | |
---|---|---|---|
propertyRecord | PropertyRecord | The property being updated. | |
setFocus | undefined | boolean | Indicates whether the Property Editor should set focus | |
title | undefined | string | Tooltip text |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023