WithDragSourceProps<DragDropObject> Interface
Deprecated in 2.x. Obsolete.
Beta
React properties for withDragSource Higher-Order Component
Properties
Name | Type | Description | |
---|---|---|---|
altDropEffect | undefined | DropEffects | Which dropEffect dragSource should be used when alt button is pressed during start of drag. | |
ctrlDropEffect | undefined | DropEffects | Which dropEffect dragSource should be used when ctrl button is pressed during start of drag. | |
defaultDropEffect | undefined | DropEffects | Which dropEffect dragSource should default to. | |
dragProps | DragSourceProps<DragDropObject> | Properties and callbacks for DragSource. | |
dragStyle | undefined | CSSProperties | Style properties for dropTarget wrapper element |
Defined in
Last Updated: 20 June, 2023