DragSourceProps<DragDropObject> Interface
Deprecated in 2.x. Obsolete.
Beta
Properties and callbacks for the withDragSource Higher-Order Component.
Methods
Name | Description | |
---|---|---|
onDragSourceBegin(data: DragSourceArguments<DragDropObject>): DragSourceArguments<DragDropObject> Optional | Triggered when DragSource has begun a drag. | |
onDragSourceEnd(data: DragSourceArguments<DragDropObject>): void Optional | Triggered when a DragSource drag has ended. |
Properties
Name | Type | Description | |
---|---|---|---|
defaultDragLayer | undefined | ComponentType<DragLayerProps<DragDropObject>> | Specifies a default DragLayer component to display as a drag preview. | |
objectType | string | symbol | (data?: DragDropObject) => string | symbol | Specifies the DragSource type. |
Defined in
Last Updated: 20 June, 2023