DragSourceArguments<DragDropObject> Interface
Deprecated in 2.x. Obsolete.
Beta
Interface for arguments supplied to DragSource callbacks, including onDragSourceBegin, and onDragSourceEnd, as well as to the DragLayers as a prop.
Extends
- DragDropArguments<DragDropObject>
Properties
Name | Type | Description | |
---|---|---|---|
defaultDragLayer | undefined | ComponentType<DragLayerProps<DragDropObject>> | ||
parentObject | undefined | DragDropObject | Parent object, using the data structure relevant to object being used. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
clientOffset | { x: number, y: number } | DragDropArguments<DragDropObject> | Current mouse position. |
col | undefined | number | DragDropArguments<DragDropObject> | specifies the col to be dropped onto. |
dataObject | DragDropObject | DragDropArguments<DragDropObject> | Arbitrary data being transferred. |
dragRect | undefined | DOMRect | DragDropArguments<DragDropObject> | DOMRect object of dragSource. |
dropEffect | DropEffects | DragDropArguments<DragDropObject> | Drop Effect of current drag |
dropRect | undefined | DOMRect | DragDropArguments<DragDropObject> | DOMRect object of current dropTarget, if available. |
dropStatus | DropStatus | DragDropArguments<DragDropObject> | Status of current drop |
initialClientOffset | { x: number, y: number } | DragDropArguments<DragDropObject> | Mouse position at beginning of drag. |
initialSourceClientOffset | undefined | { x: number, y: number } | DragDropArguments<DragDropObject> | Position of top left corner of current dragSource, measured at beginning of drag. |
local | undefined | boolean | DragDropArguments<DragDropObject> | determines whether item is dropped on same structure as the drag source, or a different structure. |
row | undefined | number | DragDropArguments<DragDropObject> | specifies the row to be dropped onto. |
sourceClientOffset | undefined | { x: number, y: number } | DragDropArguments<DragDropObject> | Current mouse position, offset by the difference between initial mouse position and initial dragSource offset. |
Defined in
Last Updated: 20 June, 2023