DragDropArguments<DragDropObject> Interface
Deprecated in 2.x. Obsolete.
Beta
Base DragDropArguments interface, used by both DragSourceArguments and DragTargetArguments.
Properties
Name | Type | Description | |
---|---|---|---|
clientOffset | { x: number, y: number } | Current mouse position. | |
col | undefined | number | specifies the col to be dropped onto. | |
dataObject | DragDropObject | Arbitrary data being transferred. | |
dragRect | undefined | DOMRect | DOMRect object of dragSource. | |
dropEffect | DropEffects | Drop Effect of current drag | |
dropRect | undefined | DOMRect | DOMRect object of current dropTarget, if available. | |
dropStatus | DropStatus | Status of current drop | |
initialClientOffset | { x: number, y: number } | Mouse position at beginning of drag. | |
initialSourceClientOffset | undefined | { x: number, y: number } | Position of top left corner of current dragSource, measured at beginning of drag. | |
local | undefined | boolean | determines whether item is dropped on same structure as the drag source, or a different structure. | |
row | undefined | number | specifies the row to be dropped onto. | |
sourceClientOffset | undefined | { x: number, y: number } | Current mouse position, offset by the difference between initial mouse position and initial dragSource offset. |
Defined in
Last Updated: 20 June, 2023