withDragSource Function
Deprecated in 2.x. Obsolete.
Beta HOC (Higher-Order Component) that transforms wrapped component into a DragSource.
withDragSource<ComponentProps extends { T }, DragDropObject>(Component: ComponentType<ComponentProps>): DndComponentClass<, ComponentProps & WithDragSourceProps<DragDropObject>>
Parameter | Type | Description |
---|---|---|
Component | ComponentType<ComponentProps> | component to wrap. |
Returns - DndComponentClass<, ComponentProps & WithDragSourceProps<DragDropObject>>
Defined in
Last Updated: 20 June, 2023