DropTargetArguments<DragDropObject> Interface
Deprecated in 2.x. Obsolete.
Beta
Interface for arguments supplied to DropTarget callbacks, including onDropTargetOver, onDropTargetDrop, and canDropTargetDrop.
Extends
- DragSourceArguments<DragDropObject>
Properties
Name | Type | Description | |
---|---|---|---|
dropLocation | undefined | DragDropObject | Object that is being dropped onto, using the data structure relevant to object being used. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
clientOffset | { x: number, y: number } | DragSourceArguments<DragDropObject> | Current mouse position. |
col | undefined | number | DragSourceArguments<DragDropObject> | specifies the col to be dropped onto. |
dataObject | DragDropObject | DragSourceArguments<DragDropObject> | Arbitrary data being transferred. |
defaultDragLayer | undefined | ComponentType<DragLayerProps<DragDropObject>> | DragSourceArguments<DragDropObject> | |
dragRect | undefined | DOMRect | DragSourceArguments<DragDropObject> | DOMRect object of dragSource. |
dropEffect | DropEffects | DragSourceArguments<DragDropObject> | Drop Effect of current drag |
dropRect | undefined | DOMRect | DragSourceArguments<DragDropObject> | DOMRect object of current dropTarget, if available. |
dropStatus | DropStatus | DragSourceArguments<DragDropObject> | Status of current drop |
initialClientOffset | { x: number, y: number } | DragSourceArguments<DragDropObject> | Mouse position at beginning of drag. |
initialSourceClientOffset | undefined | { x: number, y: number } | DragSourceArguments<DragDropObject> | Position of top left corner of current dragSource, measured at beginning of drag. |
local | undefined | boolean | DragSourceArguments<DragDropObject> | determines whether item is dropped on same structure as the drag source, or a different structure. |
parentObject | undefined | DragDropObject | DragSourceArguments<DragDropObject> | Parent object, using the data structure relevant to object being used. |
row | undefined | number | DragSourceArguments<DragDropObject> | specifies the row to be dropped onto. |
sourceClientOffset | undefined | { x: number, y: number } | DragSourceArguments<DragDropObject> | Current mouse position, offset by the difference between initial mouse position and initial dragSource offset. |
Defined in
Last Updated: 20 June, 2023