ShowHideDialogProps<T extends ShowHideID> Interface
Properties for the ShowHideDialog component used in the Table to show/hide columns.
Extends
Methods
Name | Description | |
---|---|---|
onShowHideChange(cols: T[]): undefined | boolean Optional | Called when item is shown/hidden |
Inherited methods
Name | Inherited from | Description |
---|---|---|
onClose(): void Optional | GlobalDialogProps | onClick event for X button for dialog |
onEscape(): void Optional | GlobalDialogProps | 'keyup' event for Esc key |
onModelessPointerDown(event: PointerEvent<Element>, id: string): void Optional | GlobalDialogProps | Pointer Down event handler when modeless (modal = false) |
onOutsideClick(event: MouseEvent): any Optional | GlobalDialogProps | Triggered when a click is triggered outside of this dialog. |
Properties
Name | Type | Description | |
---|---|---|---|
initialHidden | undefined | T[] | Hidden list to start with | |
items | ShowHideItem<T>[] | key-label pair list for id's to be shown/hidden, and an accompanying label. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
alignment | undefined | DialogAlignment | GlobalDialogProps | Default alignment of dialog. |
backgroundStyle | undefined | CSSProperties | GlobalDialogProps | Custom CSS Style for overlay |
buttonCluster | undefined | DialogButtonDef[] | GlobalDialogProps | List of DialogButtonDef objects specifying buttons and associated onClick events |
contentClassName | undefined | string | GlobalDialogProps | Custom CSS class name for the content |
contentStyle | undefined | CSSProperties | GlobalDialogProps | Custom CSS Style for the content |
footer | string | Element | GlobalDialogProps | Footer to show at bottom of dialog. |
footerStyle | undefined | CSSProperties | GlobalDialogProps | Custom CSS Style for footer |
header | undefined | ReactNode | GlobalDialogProps | Override for the header |
height | string | number | GlobalDialogProps | Initial height of dialog. |
hideHeader | undefined | boolean | GlobalDialogProps | Whether the hide the header. |
identifier | undefined | string | GlobalDialogProps | |
inset | undefined | boolean | GlobalDialogProps | Indicates whether the content should be inset. |
itemId | undefined | string | GlobalDialogProps | Optional unique identifier for item. |
maxHeight | string | number | GlobalDialogProps | Maximum height that the dialog may be resized to. |
maxWidth | string | number | GlobalDialogProps | Maximum width that the dialog may be resized to. |
minHeight | string | number | GlobalDialogProps | Minimum height that the dialog may be resized to. |
minWidth | string | number | GlobalDialogProps | Minimum width that the dialog may be resized to. |
modal | undefined | boolean | GlobalDialogProps | Whether to show background overlay. |
modelessId | undefined | string | GlobalDialogProps | An id for a modeless dialog |
movable | undefined | boolean | GlobalDialogProps | Indicates whether the user can move dialog with cursor. |
opened | boolean | GlobalDialogProps | Indicates whether to show dialog or not |
resizable | undefined | boolean | GlobalDialogProps | Indicates whether the user can resize dialog with cursor. |
title | string | Element | GlobalDialogProps | Title to show in title bar of dialog |
titleStyle | undefined | CSSProperties | GlobalDialogProps | Custom CSS Style for title |
trapFocus | undefined | boolean | GlobalDialogProps | Indicates whether the focus should be trapped within the dialog. |
width | string | number | GlobalDialogProps | Initial width of dialog. |
x | undefined | number | GlobalDialogProps | Initial x/left position of dialog in px. |
y | undefined | number | GlobalDialogProps | Initial y/top position of dialog in px. |
Defined in
Last Updated: 20 June, 2023