BreadcrumbDetailsProps Interface
Deprecated in 3.0. Use Breadcrumbs from @itwin/itwinui-react.
Beta
Properties for the BreadcrumbDetails component
Extends
Methods
Name | Description | |
---|---|---|
onChildrenLoaded(parent: TreeNodeItem, children: TreeNodeItem[]): void Optional | Callback triggered when child node is loaded with an asynchronous dataProvider. | |
onRender(): void Optional | ||
onRootNodesLoaded(nodes: TreeNodeItem[]): void Optional | Callback triggered when root nodes are loaded with an asynchronous dataProvider. | |
renderTable(props: TableProps, node: undefined | TreeNodeItem, children: TreeNodeItem[]): ReactNode Optional |
Properties
Name | Type | Description | |
---|---|---|---|
columns | undefined | ColumnDescription[] | ||
path | BreadcrumbPath | Path data object shared by Breadcrumb component |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023