constructor Method

Constructor for ConditionalBooleanValue. It is important that the same ConditionalBooleanValue instance is not used by multiple UI item definitions in order that the control's state is always rendered correctly.

ConditionalBooleanValue(testFunc: () => boolean, syncEventIds: string[], value?: boolean): ConditionalBooleanValue

Parameter Type Description
testFunc () => boolean Function to run to retrieve the value for the conditional. This function is run when refresh method is called or if the value is not defined in the constructor.
syncEventIds string[] An array of eventId that should be monitored to determine when to run the refresh method.
value boolean The default value for the conditional value. If not specified then the function is run to set the value when the value is retrieved.

Returns - ConditionalBooleanValue

Defined in

Last Updated: 20 June, 2023