constructor Method

Overloads
constructorToolSettings(props)  
constructorToolSettings(props, context?) Deprecated  

ToolSettings(props)

ToolSettings(props: Readonly<ToolSettingsProps>): ToolSettings

Parameter Type Description
props Readonly<ToolSettingsProps>  

Returns - ToolSettings



ToolSettings(props, context?)

Deprecated  

ToolSettings(props: ToolSettingsProps, context?: any): ToolSettings

see https://reactjs.org/docs/legacy-context.html

Parameter Type Description
props ToolSettingsProps  
context any  

Returns - ToolSettings


Last Updated: 11 June, 2024