getWidgetDefs Method

Get WidgetDefs matching the given criteria.

getWidgetDefs(stageId: string, stageUsage: string, location: ZoneLocation | StagePanelLocation, section?: StagePanelSection): undefined |

note It is recommended to provide custom unique ids to returned widget defs. Semi-stable id is used when auto-generated widgetDef id is detected, but correctness of such id depends on widget index in the returned array.

Parameter Type Description
stageId string  
stageUsage string  
location ZoneLocation | StagePanelLocation  
section StagePanelSection  

Returns - undefined |

Last Updated: 11 June, 2024