saveSharedSetting Method

Saves a shared settings object to the settings service.

saveSharedSetting(requestContext: AuthorizedClientRequestContext, settings: any, namespace: string, name: string, applicationSpecific: boolean, projectId: string, iModelId?: string): Promise<SettingsResult>

Parameter Type Description
requestContext AuthorizedClientRequestContext The client request context.
settings any The object to be saved. It is saved as a JSON string.
namespace string A program-supplied namespace that is used to organize settings and prevent name collisions.
name string The name of the setting. Acceptable characters are alphanumeric and the period character.
applicationSpecific boolean Specifies whether the setting is specific to the current application, or used by all applications.
projectId string The wsgId of the Project, if the settings is specific to a project, otherwise undefined.
iModelId string The wsgId of the iModel, if the setting is specific to an iModel, otherwise undefined. The projectId must be specified if iModelId is specified.

Returns - Promise<SettingsResult>

The result of the save operation. The setting member is undefined for save operations.

Last Updated: 11 June, 2024