deleteSharedSetting Method

Deletes a shared settings object from the settings service.

deleteSharedSetting(requestContext: AuthorizedClientRequestContext, namespace: string, name: string, applicationSpecific: boolean, projectId: string, iModelId?: string): Promise<SettingsResult>

Parameter Type Description
requestContext AuthorizedClientRequestContext  
namespace string A program-supplied namespace that is used to organize settings and prevent name collisions.
name string The name of the setting. Acceptable characters are alphanumeric and the period character.
applicationSpecific boolean Specifies whether the setting is specific to the current application, or used by all applications.
projectId string The wsgId of the Project (required for Shared Setting).
iModelId string The wsgId of the iModel, if the setting is specific to an iModel, otherwise undefined.

Returns - Promise<SettingsResult>

The result of the save operation. The setting member is undefined for delete operations. If the setting specified for deletion does not exists, the SettingsResult.status is SettingsStatus.SettingNotFound.

Last Updated: 11 June, 2024