deleteSetting Method

Deletes a non-user-specific settings object from the settings service.

deleteSetting(requestContext: AuthorizedClientRequestContext, namespace: string, name: string, applicationSpecific: boolean, projectId?: string, iModelId?: string): Promise<SettingsResult>

note The logged in user must have the appropriate permissions to delete a non-user-specific setting.

Parameter Type Description
requestContext AuthorizedClientRequestContext The client request context.
namespace string A program-supplied namespace that is used to organize settings and prevent name collisions.
name string The name of the setting. Acceptable characters are alphanumeric and the period character.
applicationSpecific boolean Specifies whether the setting is specific to the current application, or used by all applications.
projectId string The wsgId of the Project, if the settings is specific to a project, otherwise undefined.
iModelId string The wsgId of the iModel, if the setting is specific to an iModel, otherwise undefined. The projectId must be specified if iModelId is specified.

Returns - Promise<SettingsResult>

The result of the save operation. The setting member is undefined for delete operations. If the setting specified for deletion does not exists, the SettingsResult.status is SettingsStatus.SettingNotFound.

Last Updated: 11 June, 2024