getDistinctValues Method

Deprecated  Use PresentationManager.getPagedDistinctValues

Retrieves distinct values of specific field from the content based on the supplied content descriptor override.

getDistinctValues(requestOptions: ContentRequestOptions<IModelConnection, RulesetVariable>, descriptorOrOverrides: Descriptor | DescriptorOverrides, keys: KeySet, fieldName: string, maximumValueCount: number = 0): Promise<string[]>

Parameter Type Description
requestOptions ContentRequestOptions<IModelConnection, RulesetVariable> options for the request
descriptorOrOverrides Descriptor | DescriptorOverrides Content descriptor which specifies how the content should be returned.
keys KeySet Keys of ECInstances to get the content for.
fieldName string Name of the field from which to take values.
maximumValueCount number Maximum numbers of values that can be returned. Unlimited if 0.

Returns - Promise<string[]>

A promise object that returns either distinct values on success or an error string on error.

Defined in

Last Updated: 11 June, 2024