fromJSON MethodStatic

Overloads
fromJSON(json, categories) Static  
fromJSON(json) Static Deprecated  

fromJSON(json, categories)

Deserialize Field from JSON

fromJSON(json: undefined | FieldJSON<ClassInfoJSON>, categories: CategoryDescription[]): undefined | Field

Parameter Type Description
json undefined | FieldJSON<ClassInfoJSON>  
categories CategoryDescription[]  

Returns - undefined | Field



fromJSON(json)

Deprecated  Use an overload that takes a list of categories

Deserialize Field from JSON

fromJSON(json: undefined | string | FieldJSON<ClassInfoJSON>): undefined | Field

Parameter Type Description
json undefined | string | FieldJSON<ClassInfoJSON>  

Returns - undefined | Field


Defined in

Last Updated: 11 June, 2024