PresentationPropsDeprecated Interface
Extends
Methods
Name | Description | |
---|---|---|
clientManagerFactory(clientId: string, props: PresentationManagerProps): PresentationManager Optional | Factory method for creating separate managers for each client |
Properties
Name | Type | Description | |
---|---|---|---|
requestTimeout | undefined | number | Time in milliseconds after which the request will timeout. | |
unusedClientLifetime | undefined | number | How much time should an unused client manager be stored in memory |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
activeLocale | undefined | string | PresentationManagerProps | Sets the active locale to use when localizing presentation-related |
activeUnitSystem | undefined | PresentationUnitSystem | PresentationManagerProps | Sets the active unit system to use for formatting property values with |
cacheConfig | undefined | HierarchyCacheConfig | PresentationManagerProps | A configuration for Presentation hierarchy cache. |
contentCacheSize | undefined | number | PresentationManagerProps | |
defaultFormats | undefined | { T } | PresentationManagerProps | A map of default unit formats to use for formatting properties that don't have a presentation format |
enableSchemasPreload | undefined | boolean | PresentationManagerProps | Should schemas preloading be enabled. |
localeDirectories | undefined | string[] | PresentationManagerProps | A list of directories containing application's locale-specific localized |
mode | undefined | PresentationManagerMode | PresentationManagerProps | Presentation manager working mode. |
presentationAssetsRoot | string | { backend: string, common: string } | PresentationManagerProps | Path overrides for presentation assets. |
rulesetDirectories | undefined | string[] | PresentationManagerProps | A list of directories containing application's presentation rulesets. |
supplementalRulesetDirectories | undefined | string[] | PresentationManagerProps | A list of directories containing application's supplemental presentation rulesets. |
taskAllocationsMap | undefined | { T } | PresentationManagerProps | A map of 'priority' to 'number of slots allocated for simultaneously running tasks' |
updatesPollInterval | undefined | number | PresentationManagerProps | The interval (in milliseconds) used to poll for presentation data changes. |
useMmap | number | boolean | PresentationManagerProps | Use SQLite's Memory-Mapped I/O for worker connections. |
workerConnectionCacheSize | undefined | number | PresentationManagerProps | Each slot (see PresentationManagerProps.taskAllocationsMap) may open a worker connection to an iModel used for a request. |
Defined in
Last Updated: 11 June, 2024