getNodes Method

Overloads
getNodes(requestOptions)  
getNodes(requestContext, requestOptions, parentKey?) Deprecated  

getNodes(requestOptions)

Retrieves nodes

getNodes(requestOptions: WithClientRequestContext<Paged<ExtendedHierarchyRequestOptions<IModelDb, NodeKey, RulesetVariable>>>): Promise<Node[]>

Parameter Type Description
requestOptions WithClientRequestContext<Paged<ExtendedHierarchyRequestOptions<IModelDb, NodeKey, RulesetVariable>>>  

Returns - Promise<Node[]>



getNodes(requestContext, requestOptions, parentKey?)

Deprecated  Use an overload with ExtendedHierarchyRequestOptions

Retrieves nodes

getNodes(requestContext: ClientRequestContext, requestOptions: Paged<HierarchyRequestOptions<IModelDb, RulesetVariable>>, parentKey?: NodeKey): Promise<Node[]>

Parameter Type Description
requestContext ClientRequestContext  
requestOptions Paged<HierarchyRequestOptions<IModelDb, RulesetVariable>>  
parentKey NodeKey  

Returns - Promise<Node[]>


Defined in

Last Updated: 11 June, 2024