FluentdBunyanLoggerConfig Class
Beta
Helps to configure the bentleyjs-core Logger to use fluentd and seq. Note: The app must depend on the bunyan, request and request-promise packages.
Methods
Name | Description | |
---|---|---|
constructor(): FluentdBunyanLoggerConfig | ||
createBunyanFluentdLogger(fluentdConfig: IFluentdConfig, loggerName: string): any Static | Create a bunyan logger that streams to fluentd | |
validateProps(fluentdConfig: any): void Static | Check that the specified object is a valid SeqConfig. |
Defined in
- FluentdBunyanLoggerConfig.ts Line 17
Last Updated: 11 June, 2024