setupOptionDefaults MethodProtected

Augments request options with defaults returned by the DefaultWsgRequestOptionsProvider.

setupOptionDefaults(options: RequestOptions): Promise<void>

note that the options passed in by clients override any defaults where necessary.

Parameter Type Description
options RequestOptions Options the caller wants to augment with the defaults.

Returns - Promise<void>

Promise resolves after the defaults are setup.

Defined in

Last Updated: 11 June, 2024