fromJson MethodStatic

Beta  

Creates a strongly typed UserInfo object from untyped JSON with the same properties as UserInfo

fromJson(jsonObj: UserInfoProps): UserInfo

see UserInfo.fromTokenResponseJson for use cases that involve parsing responses from typical Authorization Client-s.

throws BentleyError if the supplied json parameter is undefined

Parameter Type Description
jsonObj UserInfoProps  

Returns - UserInfo

Defined in

Last Updated: 11 June, 2024