TwoWayViewportSync Class
Forms a bidirectional connection between two Viewports such that the Frustums of both Viewports are synchronized. For example, panning in one viewport will cause the other viewport to pan by the same distance.
see Multiple Viewport Sample for an interactive demonstration.
Methods
Name | Description | |
---|---|---|
constructor(): TwoWayViewportSync | ||
connect(view1: Viewport, view2: Viewport): void | Establish the connection between two Viewports. | |
disconnect(): void | Remove the connection between the two views. |
Defined in
Last Updated: 11 June, 2024