create MethodStatic

Create and return a SkyCube. (Calls the SkyCube constructor after validating the Ids passed in for the images.)

create(front: string, back: string, top: string, bottom: string, right: string, left: string, display?: boolean): undefined | SkyCube

note All Ids must refer to a persistent texture element stored in the iModel.

Parameter Type Description
front string The Id of the image to use for the front side of the sky cube.
back string The Id of the image to use for the back side of the sky cube.
top string The Id of the image to use for the top side of the sky cube.
bottom string The Id of the image to use for the bottom side of the sky cube.
right string The Id of the image to use for the right side of the sky cube.
left string The Id of the image to use for the left side of the sky cube.
display boolean  

Returns - undefined | SkyCube

A SkyCube, or undefined if any of the supplied texture Ids are invalid.

Defined in

Last Updated: 11 June, 2024