create MethodStatic

Create a new context for frontend operations to pass to various services that require authorization. Uses the authorization information supplied to IModelApp to setup an accessToken within the context.

create(activityId?: string): Promise<AuthorizedFrontendRequestContext>

throws BentleyError if the application cannot be authorized.

see IModelApp.authorizationClient to setup authorization for the frontend application.

Parameter Type Description
activityId string  

Returns - Promise<AuthorizedFrontendRequestContext>

Defined in

Last Updated: 11 June, 2024