updateProjectExtents Method

Update the project extents of this iModel.

updateProjectExtents(newExtents: Range3d): Promise<void>

throws IModelError if the IModelConnection is read-only or there is a problem updating the extents.

Parameter Type Description
newExtents Range3d The new project extents as an AxisAlignedBox3d

Returns - Promise<void>

Defined in

Last Updated: 11 June, 2024