clone Method

Create a copy of this ThematicGradientSettings, optionally modifying some of its properties.

clone(changedProps?: ThematicGradientSettingsProps): ThematicGradientSettings

Parameter Type Description
changedProps ThematicGradientSettingsProps JSON representation of the properties to change.

Returns - ThematicGradientSettings

A ThematicGradientSettings with all of its properties set to match those of this, except those explicitly defined in changedProps.

Defined in

Last Updated: 11 June, 2024