CreateIModelProps Interface
The properties that can be supplied when creating a new iModel.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
client | undefined | string | Client name for new iModel | |
guid | undefined | string | The GUID of new iModel. | |
thumbnail | undefined | ThumbnailProps | Thumbnail for new iModel |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
ecefLocation | undefined | EcefLocationProps | IModelProps | The location of the iModel in Earth Centered Earth Fixed coordinates. |
geographicCoordinateSystem | undefined | GeographicCRSProps | IModelProps | The Geographic Coordinate Reference System indicating the projection and datum used. |
globalOrigin | undefined | XYZProps | IModelProps | An offset to be applied to all spatial coordinates. |
name | undefined | string | IModelProps | The name of the iModel. |
projectExtents | undefined | Range3dProps | IModelProps | The volume of the entire project, in spatial coordinates |
rootSubject | RootSubjectProps | IModelProps | The name and description of the root subject of this iModel |
Defined in
- core/common/src/IModel.ts Line 105
Last Updated: 11 June, 2024