fromGeometricElement2d MethodStatic

Create a new GeometryStream iterator for a GeometricElement2d. If GeometricElement2dProps.placement is not undefined, placement relative entries will be returned transformed to world coordinates.

fromGeometricElement2d(element: GeometricElement2dProps): GeometryStreamIterator

throws IModelError if element.geom is undefined.

Parameter Type Description
element GeometricElement2dProps  

Returns - GeometryStreamIterator

Defined in

Last Updated: 11 June, 2024