clone Method

Create a copy of this TerrainSettings, optionally modifying some of its properties.

clone(changedProps?: TerrainProps): TerrainSettings

Parameter Type Description
changedProps TerrainProps JSON representation of the properties to change.

Returns - TerrainSettings

A TerrainSettings with all of its properties set to match those ofthis, except those explicitly defined in changedProps.

Defined in

Last Updated: 11 June, 2024